- Email Delivery & Authentication Service Degradation Due to Third-Party Provider Outage – Incident details

Email Delivery & Authentication Service Degradation Due to Third-Party Provider Outage

Resolved
Partial outage 10 %
Started 20 days agoLasted about 5 hours

Affected

AiBL Apps

Partial outage from 12:10 PM to 2:21 PM, Operational from 2:21 PM to 5:25 PM

Memorang Hub

Degraded performance from 12:10 PM to 2:21 PM, Operational from 2:21 PM to 5:25 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience as we worked through this incident.

  • Update
    Update

    We have implemented a workaround that has restored primary email functionality. Authentication and core email services are now working as intended. We are continuing to actively monitor the environment to ensure stability.

  • Monitoring
    Monitoring

    We’re continuing to closely monitor system performance to ensure stability.

  • Identified
    Identified

    We’ve confirmed an issue with a third-party provider that’s impacting email deliveries and some auth related services. We’re actively working to restore the services as soon as possible.